BLAD OSI TRASY PO WROWADZENIU PRZESUNIECIA NIWELETY

Pytania dotyczące obsługi programu C-Geo V8 i kolejnych edycji
podrygi
__
__
Posty: 19
Rejestracja: niedziela, 12 grudnia 2010, 22:58

BLAD OSI TRASY PO WROWADZENIU PRZESUNIECIA NIWELETY

Post autor: podrygi » niedziela, 15 września 2019, 11:54

mam problem polegajacy na tym, ze po wprowadzeniu osi trasy liczy sie wysztko ok (os trasy w srodku pasa rozdzialu) a po wprowadzeniu przesuniecia niwelety w prawo i w lewo celem prawidlowego zdefiniowania jezdni lewej i prawej pojawia sie blad dlugosci stycznych i punkty policzone w osi sa przesuniete o ok 14cm. Nie wiem w czym lezy problem czy cos robie zle czy to specyfika programu? na poprzedniej robocie robilem to w analogiczny sposob i nie byle tego problemu. Zalaczam trasy.
Załączniki
trasy.zip
(4.99 KiB) Pobrany 23 razy

Awatar użytkownika
Jurek B.
Team
Team
Posty: 6075
Rejestracja: środa, 16 lutego 2005, 21:25

Re: BLAD OSI TRASY PO WROWADZENIU PRZESUNIECIA NIWELETY

Post autor: Jurek B. » środa, 18 września 2019, 10:46

U mnie na tych danych, informacja o długości stycznych większych od odległości między wierzchołkami pojawia się niezależnie od tego czy podam przesunięcie niwelety.
Moim zdaniem tak to własnie powinno się zachować, bo przesunięcie niwelety nie ma wpływu na geometrię osi trasy.
Z geometrii tej trasy wynika, że jeden z łuków jest zbyt długi w stosunku do odległości między wierzchołkami.
Pozdrawiam Jurek B.

podrygi
__
__
Posty: 19
Rejestracja: niedziela, 12 grudnia 2010, 22:58

Re: BLAD OSI TRASY PO WROWADZENIU PRZESUNIECIA NIWELETY

Post autor: podrygi » piątek, 20 września 2019, 11:48

w plikach w których występuje bład usunięcie odsunięcia nie poprawia nic błąd faktycznie dalej występuje, ale kiedy weżmie Pan plik wyjściowy ("środek") od którego wychodziłem w nim liczy się wszystko poprawnie a przecież definicja trasy w nim jest ta sama. Pliki lewa i prawa to ten sam plik tylko zapisany w inną nazwą po dodaniu odsunięcia niwelety. Ciekawostka polega na tym że kiedy do pliku "środek" dopisze się odsunięcie niwelety tez początkowo liczy poprawnie a po zapisaniu go i otwarciu dopiero pojawia się błąd.

Awatar użytkownika
Jurek B.
Team
Team
Posty: 6075
Rejestracja: środa, 16 lutego 2005, 21:25

Re: BLAD OSI TRASY PO WROWADZENIU PRZESUNIECIA NIWELETY

Post autor: Jurek B. » piątek, 20 września 2019, 12:20

U mnie na pliku "środek" wyniki dla punktów głównych i pośrednich są takie same jak dla pozostałych plików. Ostrzeżenie o niezgodności stycznych i odległości wierzchołków także się pojawia.
Pozdrawiam Jurek B.

ODPOWIEDZ