Operacje na plikach GML

Z C-Geo Wiki
Skocz do: nawigacja, szukaj
Operacje na plikach GML
Kategorie Import/eksport
GML
Ścieżka w programie Narzędzia -> Operacje na plikach GML

Operacje na GML w C-GEO – narzędzie umożliwiające przeglądanie, filtrowanie i łączenie plików GML. Znajduje się w menu Narzędzia → Operacje na GML

Funkcja umożliwia szybkie przeglądanie zawartości plików GML, sprawdzenie obecności klas obiektów (np. EGB_Budynek, EGB_Obreb, GES_Rzedna, OT_Komunikacja…) i ilości obiektów w klasach oraz tworzenie nowych plików GML zawierających wybrane dane. Narzędzie pozwala również łączyć wiele plików GML w jeden wynikowy zbiór.

Na naszym kanale na YT dostępne jest wideo z prezentacją narzędzia

Otwórz plik GML

Aby uruchomić narzędzie należy w programie C-GEO przejść do menu Narzędzia. Wybierz opcję Operacje na GML. Po uruchomieniu pojawia się okno z zakładkami, gdzie za pomocą Plik -> Otwórz plik gml można wczytać pojedynczy plik GML lub wiele plików GML na raz.

OperacjeNaPlikachGML.png

Po wskazaniu pliku GML program automatycznie analizuje jego strukturę i wyświetla informacje o dostępnych bazach danych, klasach obiektów, liczbie obiektów w każdej klasie. Dzięki temu użytkownik może szybko sprawdzić jakie dane znajdują się w pliku, czy plik zawiera interesujące obiekty, ile elementów występuje w poszczególnych klasach.

Dzielenie

Jedną z najważniejszych funkcji modułu jest możliwość rozdzielenia pliku GML na bazy, jednostki ewidencyjne lub obręby oraz możliwość zapisania do nowego pliku GML tylko wybranych danych. Użytkownik może zaznaczyć całe bazy danych, wybrać pojedyncze klasy obiektów, ograniczyć eksport wyłącznie do potrzebnych elementów. Pozwala to znacząco zmniejszyć wielkość pliku oraz uprościć dalszą pracę na danych.

DzielenieOpcje.png

Obszar eksportu wybiera się w zakładce Dzielenie (zrzut powyżej):

  • Podziel plik na bazy - eksport do plików z podziałem na bazy. Po wywołaniu funkcji wyświetla się komunikat z listą plików, które zostaną wydzielone i okno do wskazania miejsca zapisu pliku. Domyślnie nazwą plików wynikowych jest nazwa pliku wyjściowego z dopiskiem oznaczenia bazy (...-EGiB.gml)/...-BDOT500.gml/...-GESUT.gml).
  • Podziel plik na jednostki ewidencyjne - eksport do plików z podziałem na jednostki ewidencyjne. Po wywołaniu funkcji wyświetla się komunikat z listą plików, które zostaną wydzielone i okno do wskazania miejsca zapisu pliku. Domyślnie nazwą plików są numery jednostek.
  • Podziel plik na obręby ewidencyjne - eksport do plików z podziałem na jednostki ewidencyjne. Po wywołaniu funkcji wyświetla się komunikat z listą plików, które zostaną wydzielone i okno do wskazania miejsca zapisu pliku. Domyślnie nazwą plików są numery obrębów wraz z jednostką.
  • Podziel plik według wybranych klas - wyeksportowane zostają elementy zaznaczone w oknie. Użytkownik może zaznaczyć całe bazy danych, wybrać pojedyncze klasy obiektów lub ograniczyć eksport wyłącznie do potrzebnych elementów (zrzut poniżej).
    WybraneObPlikuGML.png
  • Podziel plik według zadanego obszaru - eksport elementów znajdujących się i stycznych do wskazanego obszaru. Po wywołaniu narzędzia uruchamia się okno do wskazania pliku tekstowego ze współrzędnymi obszaru ograniczającego eksport. Można je pozyskać np. z C-GEO w edytorze obiektu (zrzut poniżej).
    WyciecieGMLDoobszaru.png
    Po wskazaniu pliku ze współrzędnymi wyświetla się okno do wskazania współrzędnych X i Y w pliku txt (zrzut poniżej).
    WyciecieGMLDoobszaru2.png

Podczas zapisu nowego pliku, wydzielając go według wybranych klas lub zadanego obszaru dostępna po wyborze miejsca zapisu pojawia się okno z komunikatami:

  • Dołącz obiekty z relacjami od - zaznaczenie opcji spowoduje dodanie do pliku wynikowego obiektów połączonych relacyjnie. Dołączone będą obiekty, do których relacje są zawarte w eksportowanym obiekcie. Jeżeli chcemy wyeksportować obiekt, który ma relacje do wysyłanego obiektu należy skorzystać z opcji Dołącz obiekty z relacjami do.
  • Dołącz obiekty z relacjami do - zaznaczenie opcji spowoduje dodanie do pliku wynikowego obiektów połączonych relacyjnie. Dołączone będą obiekty, które mają relacje do wysyłanych obiektów. Jeżeli chcemy wyeksportować obiekty, do których relacja jest w eksportowanych obiektach należy skorzystać z opcji Dołącz obiekty z relacjami od.
  • Otwórz plik wynikowy - zaznaczenie opcji spowoduje otwarcie wyeksportowanego pliku GML w narzędziu Operacje GML.

CzyZapisacPowiazaneObiekty.png

Łączenie

Moduł umożliwia scalanie wielu plików GML w jeden plik wynikowy. W tym celu należy wybrać przycisk Łączenie i na liście wskazać pliki do połączenia (zrzut poniżej), następnie kliknąć w przycisk Zapisz i określić lokalizację pliku wynikowego.

Funkcja może być wykorzystywana m.in. do łączenia danych z kilku obrębów, scalania osobnych baz BDOT500 i GESUT, przygotowania jednego zbiorczego pliku do dalszej pracy.

ZapiszPolaczoneGML.png

Filtracja

W zakładce filtry dostępne są pozycje:

  • Filtruj po bazach
  • Filtruj po jednostkach ewidencyjnych
  • Filtruj po obrębach ewidencyjnych

Efekt wyboru filtracji widoczny jest na liście oraz na dole okna (zrzut poniżej).

OperacjaNaGMLfiltracja.png

==